指数牛-专注上证指数行情走势图、沪深300指数股指期货技术分析

通达信指标公式----红色警戒

大道至简 33 0

今天给大家分享一个通达信指标公式----红色警戒,是不是想起红警了?对,这个指标就是一个预警区域,看下面演示图:

 通达信指标公式红色警戒图1

上证指数行情----通达信指标公式----红色警戒----图1)

 通达信指标公式红色警戒图1

(上证指数行情----通达信指标公式----红色警戒----图2)

指标公式源码如下:

VAR2:=LLV(LOW,33);

VAR3:=HHV(HIGH,21);

VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,20)*0.998;

100,STICK,LINETHICK9,COLOR002DB3;{极度危险区}

80,STICK,LINETHICK9,COLOR003CEC;{危险区}

50,STICK,LINETHICK9,COLOR3165FF;{安全区}

20,STICK,LINETHICK9,COLOR6F93FF;{高安全区}

80,COLORYELLOW;{黄色线}

50,COLORYELLOW;{黄色线}

20,COLORYELLOW;{黄色线}

DRAWTEXT(FILTER(CLOSE>0,25),88,'极度危险区'),COLORWHITE;{白色字}

DRAWTEXT(FILTER(CLOSE>0,25),65,'危险区'),COLORWHITE;{白色字}

DRAWTEXT(FILTER(CLOSE>0,25),30,'安全区'),COLORWHITE;{白色字}

DRAWTEXT(FILTER(CLOSE>0,25),10,'高安全区'),COLORWHITE;{白色字}

EMA(0.667*REF(VAR4,1)+0.333*VAR4,1),CIRCLEDOT,LINETHICK2,COLORFF6600;{蓝色小圆圈}

注:此公式改编自网络

公式解读:

  • 警戒区分为4个区域,分别为高安全区、安全区、危险区、极度危险区;

  • 蓝色小圆圈所处警戒区的位置表示股价的安全度,比如上证指数目前处于安全区;

  • 当股价处于安全区、高安全区时,可以结合其它技术或技术指标考虑买入股票

  • 当股价处于危险区、极度危险区时,应注意风险,可以结合其它技术或技术指标考虑卖出股票;

  • 当股价出现大幅上涨时,该指标容易出现钝化现象,即虽然该指标提示股价处于极度危险区,但股价还是继续上涨,可参考上图2所示。

指标公式的修改:

有能力者可以在目前代码的基础上,加上自己的理念,使之更加完善。能力有限者,可以简单的修改一下公式输出线条的颜色,自己怎么看的舒服就改成什么颜色。颜色代码为COLOR******(COLOR开始的词),相关的颜色已经在上面公式源码里进行了说明。其它颜色代码参考这里《通达信颜色代码表

扩展阅读:

最新评论:

->暂无评论

我有话说

亲,我是萌萌牛!此时此刻您的心情……
  • 0

  • 鼓掌

    0

  • 喜欢

    0

  • 加油

    0

  • 蒙圈

    0

发表评论 (已有0条评论)

因为有你更精彩,快来评论吧~~